Ana içeriğe atla

Kayıtlar

2017 tarihine ait yayınlar gösteriliyor

Opencart 2.3+ Sipariş Geçmişi API hatası.

Eğer opencart'ta siparişleri düzenlerken "Uyarı : API erişim iznine sahip değilsiniz!" şeklinde bir uyarı alıyorsanız internette pek elle tutulur bilgi bulamayabilirsiniz.

Bu hatanın asıl sebebi opencart'ın siparişe geçmiş ekleme işini site üzerinde bile API arayüzünü kullanmaya kalkması. Anlamayan arkadaşlar için kulağını ters elinle tutmak gibi bir şey.

Halbuki kodların içerisinde eski usul düzenlenebileceği kodlar duruyor. Kendilerine iş aradıkları için olsa gerek.

Geçiçi çözüm istiyorsanız sürekli "Ayarlar > Kullanıcılar > API" den Default hesabına ikinci sekmede "Ip Adresleri" içeriğine değişen IP adresini sürekli girmek gerekiyor.

En kolay çözüm.
https://www.opencart.com/index.php?route=marketplace/extension/info&extension_id=28323
yukarıdaki linkte bulunan extension'u siteye kurduğunuzda siz ip adresiniz değiştikçe kendisi otomatik eklenecek.

Nasıl kurulacağını bilmiyorsanız. Araştırmaya devam. ...